alignment problem

Something doesn't work and you don't know why? Ask here!
User avatar
Micr0
Posts: 395
Joined: 15 Nov 2016, 15:20

Re: alignment problem

Post by Micr0 » 13 Mar 2017, 13:13

The projector resolution is a problem but I don't think it's the only problem. I think a bigger issue is that you are calibrating to too small a scale. The David chart shows calibrating objects of 500mm to the 200mm calibration scale because David doesn't have larger ones in the kit. However off the top of my head you should be calibrating with 400mm to 450mm panels. There was thread on the old form where someone posted a graphic showing the sweet spot relative to a calibration corner setup. The sweet spot being the area of the scanning volume where David is most accurate. Your 400mm long object should be scanned by a setup that was calibrated to at least 400mm x 400mm x 400mm cube (that is rotated 45deg to the normal of the line of projection). Ideally you should have that scan volume even larger. I have scanned objects about that size with 350mm panels and trimmed away the outer area of the individual resultant meshs that have been distorted. Try calibrating to the panels you have and without moving the scanner further away to capture the whole object at once try scanning in pieces and see if that helps. At least you'll know if you are on the right path.
µ

spark
Posts: 44
Joined: 06 Mar 2017, 20:44

Re: alignment problem

Post by spark » 13 Mar 2017, 20:45

i tried a smaller piece, non reflective :-)
Image
Image

the tube is aligned well, the paper around only partly good...
Why is there a hole in the fusion?

regards, spark

User avatar
Micr0
Posts: 395
Joined: 15 Nov 2016, 15:20

Re: alignment problem

Post by Micr0 » 14 Mar 2017, 13:52

So is it better overall? What is this "Hole" you ask about?
µ

spark
Posts: 44
Joined: 06 Mar 2017, 20:44

Re: alignment problem

Post by spark » 15 Mar 2017, 07:11

hi µ, there is a hole in the fuse, where it was covered by the single scans...
the hole is smaller if the resolution of the fuse is lower.

is there a "undercoverage" of points, or what is the reason?
The alignment of the roll (cylinder) is good, the paper that is peeled off is not aligned good...

spark
Posts: 44
Joined: 06 Mar 2017, 20:44

Re: alignment problem

Post by spark » 16 Mar 2017, 19:02

sharpness was set to zero. with the default setting of 2 i got the whole coverage as the single scans shows...
why causes smoothening to this hole? dont know.

spark
Posts: 44
Joined: 06 Mar 2017, 20:44

Re: alignment problem

Post by spark » 21 Mar 2017, 11:30

Imagine you are scanning a brick to keep the example simple: (in my case it was a cylinder head with complex geometry)
There is enough surface to scan and align while you have the large surface in view.
In the area where you flip over the small surface to to the other side you will have less surface for best fit alignment
and might ran into trouble of deviations. Even hard points for manual alignment might not good enough.

I made the experience that sphere targets offers a good solution to support here.
In general and in the easy way you can say by manual alignment: this sphere surface belongs to this sphere...
But its getting more accurate, if you have min 3 sphere patches by each scan that are good enough to represent eachs centerpoint.
Then you are aligning 3 points to 3 points. This behaviour has a huge advantage in critical situations.

But actual i am running into several problems:
David is not beeing able to weight references against other surfaces
David is only able to take one manual hard point to support alignment
My spheres are from wood. They need no coating (chalk), but they are not exactely round. --> Ball bearing balls next.
The sphere registrations that i tested with geomagic are good, but the surface is not taken into account any longer. Problem?

Do you also have the problem that you need to step out of david to get a better alignment?
Or are all my alignment problems still a part of deviations and not accurate scans?

regards, spark

Post Reply