DAVID 4 Scanner missing parts in scan

Write here about construction, ideas, equipment, tips n tricks etc. related to structured light scanning
Post Reply
Bubble-Flow
Posts: 1
Joined: 17 May 2018, 16:38

DAVID 4 Scanner missing parts in scan

Post by Bubble-Flow » 17 May 2018, 17:13

Hello everyone.

I am trying to scan the surface of a plate with corrugations on it for a university project. I'm using a high speed camera that does not allow live viewing on windows so I am limited to the image grabber function of david 4.
I have managed to get it to work by projecting the images through a BenQ projector using VLC and recording the sequence with my camera in a dark room. The calibration is successful, however if I try to view the calibration panels, my images are noisy and have missing parts and holes on them. I have tried anything from changing the brightness and contrast of my projector to changing the camera exposure time from 41000 to 1000 μs as well as the exposure index. I get some minor improvement but my images are still low quality and essentially useless for my project.
The sin waves on the panels are also very jittery and uneven and nothing seems to change them.
Can anyone give me any tips what I could be doing wrong or what camera/beamer properties I should be using? What could be causing the missing parts?
I have included a picture of one of my many useless results.
https://imgur.com/a/nS43UX3

Thanks

User avatar
Micr0
Posts: 264
Joined: 15 Nov 2016, 15:20

Re: DAVID 4 Scanner missing parts in scan

Post by Micr0 » 17 May 2018, 18:48

First off, the frame rate of the camera should be 1/60th sec. You will then need to better sync the projector and camera. Try adjusting the frame rate of the projector in the monitor setting till you get less jitter. nVidia and AMD both offer control panels that offer fairly precise control over this (whether they work with your specific card remains to be seen). I found that on my system an projector frame rate ~64hz worked well.
µ

bigbomber
Posts: 72
Joined: 14 Dec 2017, 18:08

Re: DAVID 4 Scanner missing parts in scan

Post by bigbomber » 18 May 2018, 12:15

Hi friend. Actually I didn't understand the problem well. But how much is the frame rate of camera? 1/60 is exposure time or shutter speed.
Why ussing high speed cam? My cam is 30 fps but when I calculate the rate on scanning it never go uppr than 23. Because my camputer hardware (cpu,Ram, GPU, ...) do not let for it. Actually david will fo a image preprocessing exactly after each frame grabbing.
As i know in omage grabber you must project the pattern one by one manually and take photos; so high speed function is unusable.

bigbomber
Posts: 72
Joined: 14 Dec 2017, 18:08

Re: DAVID 4 Scanner missing parts in scan

Post by bigbomber » 18 May 2018, 12:18

Also if u have very strange problem pn image grabber, I have good experiencesfor it. I mean fully distorted photo or rotated photos.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests